Top > プログラム > VisualStudio

目次 Edit

古いバージョンの Express Edition をダウンロードする方法 Edit

  • 「Visual Studio 2008 Express Edition」が欲しい場合、Microsoftの英語サイトに行ってダウンロードします。
    Microsoft日本語サイトで探しても2010のバージョンのものしか見つからないようです。
    http://www.microsoft.com/express/Downloads/#%20
    ここから Visual Studio 2008 Express → Japanese を選択してダウンロード。

お得に Visual Studio 2010 Professional を購入する方法 Edit

まともに買うと12万円くらい取られます。
アップグレード版などをうまいこと使うと、5万円程度に抑えられます。

  1. 「Visual Studio 2008 Standard Edition アップグレード」を購入。
    アップグレードは無料の Express Edition にも適用できてしまうというありがたい仕様なので、
    手元に何も無くても大丈夫です。
    情報によると、Express Editionすらなくても問題なくインストールできるようです。

  2. 「Microsoft Visual Studio 2010 Professional 乗換優待パッケージ」を購入。
    2008のStandard Editionからこのパッケージで2010にアップグレードします。
    このパッケージは10,000本限定らしいので、ご購入はお早めに…。

pgomgrを利用したプロファイリング(ボトルネック調査) Edit

  1. ソリューションエクスプローラのプロジェクト右クリック「ガイド付き最適化のプロファイル」>「インストルメント」でビルド。
  2. 同じメニューから「インストルメントまたは最適化されたアプリケーションの実行」で実行。
  3. 同じメニューから「最適化」を実行。
  4. pgdファイルが出力されるので、Visual Studio 2005コマンドプロンプトを開き
    pgomgr /summary c:\hogehoge\hoge.pgd > c:\hogehoge\hoge_profile.txt
    みたいな感じで最終的なプロファイル結果のテキストを出力する。

参考サイト
http://soundengine.jp/services/tips/?date=2007-12-26

「Visual C# 2008 Express Edition」→ 「Visual Studio 2008 Standard Edition」に移行する時に出たエラーの解消方法メモ Edit

Microsoft.VisualStudio.Xaml ({E58C2A8B-BCC4-4559-AD59-D62EB6D58A22}) は、以前のエラーが原因で読み込むことができませんでした。
詳細についてはパッケージ開発元に問い合わせてください。
このパッケージをもう一度読み込むには、コマンド プロンプトで 'devenv /resetskippkgs' と入力してください。
  1. Express Editionをアンインストール
  2. MSのサイトから Visual Studio 2008 SP1 をダウンロードしてインストール
  3. Visual Studio 2008 の各種パッチを Microsoft Update でインストール
    http://www.microsoft.com/japan/msdn/vstudio/downloads/sp/vs2008/sp1/default.aspx
  4. なおった!

Windows 7 にVisual Studio 2005 をインストールする Edit

参考:http://support.microsoft.com/kb/936453/ja

  • 次の順にインストールする
  1. Microsoft Visual Studio 2005
    • 途中で[プログラム互換性アシスタント] の警告メッセージダイアログが表示されたら、[プログラムを実行する] ボタンを押してインストールを続行する。
  2. Microsoft Visual Studio 2005 Service Pack 1
    • VS80sp1-KB926602-X86-JPN.exe
  3. Visual Studio 2005 Service Pack 1 Update for Windows Vista
    • VS80sp1-KB932236-X86-JPN.exe

Visual Studio 2005 トラブルシューティング Edit

コンパイル時の謎エラー Edit

cl : コマンド ライン error D8027 : 'C:\Program Files\Microsoft Visual Studio 8\VC\bin\c2.dll' を実行できません

は、分散ビルド使用時にコンパイルを引き受けているエージェントのPCが特定のタイミングで落ちると発生するようです。
リビルドする必要はなく、再度ビルドで回避できます。

Visual Studio 2005 でIntelliSenceを完全に無効化する Edit

C:\Program Files\Microsoft Visual Studio 8\VC\vcpackages\feacp.dll

をリネーム(もしくは削除)する。

Visual Studio 2010 でIntelliSenceを完全に無効化する Edit

オプション>テキストエディタ>C/C++(任意の言語)>IntelliSenceの無効化
をTrueにする
VisualAssistXを使用している場合は、『#includeのオートコンプリートの無効化』もTrueにしておくと、余計なVisualStudio側の処理が走らなくて良い。

Visual Studio 2013設定メモ Edit

cpp<->hの相互ファイルオープン Edit

Hoge.cppに対応するHoge.hをいっぱつで開くためのショートカットキーを設定します。
デフォルトでは『Ctrl+K,Ctrl+O』にアサインされています。
使用頻度が高いので、『Ctrl+R』にアサインします。
VisualAssistXでいうところの、OpenCorrespondingFileに当たる処理です。
ツール>オプション>キーボード の『以下の文字列を含むコマンドを表示』に『ヘッダーの切り替え』と入れるとコマンドがフィルターされて表示されると思います。
そのコマンドを選択した状態で、ショートカットキーの箇所を選択して、『Ctrl+R』を実際に入力して、Ctrl+Rを指定します。
『使用する場所』は『テキストエディター』にしておきます。
『OK』ボタンを押して完了です。

ファイルの存在するフォルダをエクスプローラで開く Edit

ファイルが存在しているフォルダを開きたい場面が結構あるので、ショートカットキーで開けるようにします。
使用頻度が高いので『Ctrl+E』にアサインします。
まず、Ctrl+Eに余計なコマンドがアサインされているのでそいつを削除します。
ツール>オプション>キーボード の『以下の文字列を含むコマンドを表示』に『編集.[右端で折り返す]の設定解除』と入れ、フィルタされたコマンドを選択します。
Ctrl+E,Ctrl+W(テキストエディター) となっているのを確認し、『削除』ボタンで削除します。
これでCtrl+Eが空いたので、続けてコマンドをアサインします。
『以下の文字列を含むコマンドを表示』に、『ファイル.このアイテムのフォルダーを開く』を入力、『ショートカットキー』の箇所を選択し、実際に『Ctrl+E』のキーを押してCtrl+Eを入力し、『割り当て』ボタンを押します。
『OK』ボタンを押してダイアログを抜けたら、テキストエディタ上で『Ctrl+E』の操作をしてみて、エクスプローラでちゃんとフォルダが開くかを確認します。

オートコンプリート(コード補完機能)の設定 Edit

ツール>オプション>C/C++ の辺りから設定変更できます。
以下、変更した項目。

内容設定備考
自動かっこ挿入OFF/*を入力すると/**/にオートコンプリートされてしまうのでOFF
コンマの後にスペースを追加するOFF
バイナリ演算子の前後のスペースを変更しないに変更
代入演算子の前後のスペースを変更しないに変更
条件演算子の前後のスペースを変更しないに変更

個人的に Visual Studio 2013 でよく使うショートカットキーまとめ Edit

キーボードショートカットカスタマイズ分を含みます。

ショートカットキーコマンド備考
F5デバッグ.開始
Shift+F5デバッグ.デバッグの停止
F7ビルド.ソリューションのビルド
Ctrl+F7ビルド.コンパイル現在のファイルをコンパイル
Ctrl+Shift+↑or↓編集.前の強調表示された参照現在カーソル下にある単語の次(前)の使用場所へ移動します。強調表示される単語が対象で、有効なコード部分にしか移動せず、コメント部分には移動しません。コメント部分を含めた移動にはCtrl+F3を使います。
Ctrl+F3編集.次を検索範囲選択現在カーソル下にある単語をドキュメント内で検索して移動します。
Ctrl+Shift+F3編集.前を検索範囲選択Ctrl+F3の逆順です。
F12編集.定義へ移動
Alt+F12編集.定義をここに表示定義先にファイル移動するのではなく、定義をその場に表示できます。
Ctrl+,編集.移動曖昧な単語からファイルやテキストの検索などが行えます。
Shift+Alt+矢印編集.1行上まで列を選択矩形選択です。
Ctrl+Eファイル.このアイテムのフォルダーを開く
Ctrl+Rエディーターコンテキストメニュー.コードウィンドウ.ヘッダーの切り替えコードファイルcpp<->hの切り替えです。
Ctrl+Wウィンドウ.ドキュメントウィンドウを閉じる現在開いているドキュメントを閉じます。
Ctrl+Shift+Wウィンドウ.すべてのドキュメントを閉じる開いているドキュメントを全て閉じます。
Ctrl+Shift+V編集.クリップボードリングの切り替えクリップボードを参照して、過去にさかのぼってコピーしたものをペーストできます。
Ctrl+F編集.検索主に開いているドキュメント内の検索に使用します。
Ctrl+Shift+F編集.フォルダーを指定して検索主にソリューション全体から検索したい時に使用します。
Ctrl+G編集.ジャンプ現在のドキュメントの指定行にジャンプします。
Ctrl+]編集.かっこに移動かっこにカーソルを合わせた状態で入力すると、対応するかっこに移動できます。かっことは『(』『)』『{』『}』等を指します。
Ctrl+M,Ctrl+M編集.アウトラインの展開折りたたみ現在位置を展開、折りたたみします。
Ctrl+M,Ctrl+L編集.すべてのアウトラインの切り替え現在のドキュメント全体の展開、折りたたみを実行します。
Ctrl+-表示.前に戻る前回カーソル位置のあった場所に移動します。
Ctrl+Shift-表示.次に進むCtrl+-の逆順です。
F8編集.次の場所へ移動エラー一覧などの、次の項目へ移動します。

リロード   新規 編集 凍結 差分 添付 複製 名前変更   ホーム 一覧 単語検索 最終更新 バックアップ リンク元   ヘルプ   最終更新のRSS
Last-modified: 2014-03-07 (金) 18:30:32 (1172d)